LuaLib Installation error

All posts which do not fit into any other sections of the forum.

Moderator: admin

LuaLib Installation error

Postby tomrnewell » Thu Jul 28, 2016 11:00 pm

I am trying to install lualib.
I downloaded the lualib.exe file but when I try to run it I receive an error message that says it cannot write the commons file to the lualib directory.
any recommendations for how to install lualib?
last night I found a similar post but today I cannot find it again to see what the solution was.

tom
tomrnewell
 
Posts: 8
Joined: Thu Jul 28, 2016 10:27 pm

Re: LuaLib Installation error

Postby Julia CJ » Fri Jul 29, 2016 6:57 am

Hi Tom,

Do you install Lua library with running Trading Station or no? If it is true, try to install Lua library with closed Trading Station. But if in this case you see the same issue, please send the snapshot with issue message.

Thank you.
Julia CJ
 

Re: LuaLib Installation error

Postby tomrnewell » Fri Jul 29, 2016 10:05 am

I have tried both with and without fxcm running.

error message attached.

tom
Attachments
Lualib.PNG
tomrnewell
 
Posts: 8
Joined: Thu Jul 28, 2016 10:27 pm

Re: LuaLib Installation error

Postby Julia CJ » Tue Aug 02, 2016 8:25 am

Hi Tom,

Thank you for reporting of issue. We are investigating it.
I will let you know about the result as soon as we figure out the cause.
Julia CJ
 

Re: LuaLib Installation error

Postby tomrnewell » Tue Aug 02, 2016 8:04 pm

I found a post that says the install directories are in "c:\Program Files".
The Candleworks directory on my computer is in c:\Program Files(X86)"
I created a similar directory structure under "c:\Program Files" but I get the same error.
I have tried installing as administrator and regular.
I can find a common.lua.rc file under "FXTS2\strategies\standard" and in "FSTS2\directory.
are you trying to replace one or both of these or are you trying to create another directory?
tomrnewell
 
Posts: 8
Joined: Thu Jul 28, 2016 10:27 pm

Re: LuaLib Installation error

Postby tomrnewell » Thu Sep 01, 2016 10:48 am

I am still actively trying to install lualib on my computer, so far I remain unsuccessful.

Is the installation program trying to replace a common.lua.rc file under "FXTS2\strategies\standard" and in "FSTS2\directory?

Tom
tomrnewell
 
Posts: 8
Joined: Thu Jul 28, 2016 10:27 pm

Re: LuaLib Installation error

Postby Julia CJ » Tue Sep 06, 2016 6:47 am

Hi Tom,

Please reproduce the following steps:

Unpack the downloaded LuaLib.exe and copy http_lua.dll file and the LuaLib folder, which contains commons.lua, reportapi.lua and reportcache.lua to Candleworks\FXTS2 folder
Julia CJ
 

Re: LuaLib Installation error

Postby tomrnewell » Mon Sep 12, 2016 10:41 pm

When I try to launch the .exe program, the attached error pops up.

Is there another way to unpack the files?

tom
Attachments
Lualib20160912.PNG
tomrnewell
 
Posts: 8
Joined: Thu Jul 28, 2016 10:27 pm

Re: LuaLib Installation error

Postby Julia CJ » Tue Sep 13, 2016 6:19 am

Hi Tom,

For unpacking this file use 7-Zip (http://www.7-zip.org), the archiver is free.
You need to load 7-Zip and install it at your computer. After that click the right mouse button at luaLib.exe installer and chose on context menu 7-Zip -> Extract Here.
Then copy http_lua.dll file and the LuaLib folder, which contains commons.lua, reportapi.lua and reportcache.lua to Candleworks\FXTS2 folder.
Julia CJ
 

Re: LuaLib Installation error

Postby tomrnewell » Fri Oct 07, 2016 10:25 am

that worked great for extracting the files and moving them to the correct location.

Sorry for the long delay but I did not know that you had posted an answer to my last post.

now I just need to figure out how it works.

tom
tomrnewell
 
Posts: 8
Joined: Thu Jul 28, 2016 10:27 pm

Next

Return to General Discussions

Who is online

Users browsing this forum: No registered users and 2 guests