Strategy debugger problem

All posts which do not fit into any other sections of the forum.

Moderator: admin

Strategy debugger problem

Postby tllewell » Sat Oct 27, 2012 7:53 am

On the machine I normally use for Indicore SDK work, my strategy debugger cannot find the indicators called for in the strategies. On the strategy I'm working on, I noticed this yesterday when I got an error that said it could "not find an indicator with id 'PIVOT'". I tried it with the standard CCI strategy, and the same thing happened. It said it could not find an indicator with id CCI.

This is an XP machine with the SDK installed in c:\gehtsoft.

I have another machine that is identical as to the SDK, and everything works fine there.

Is there something I could fix that is causing this, like a configuration file? If I reinstall the SDK, should I delete it first?
tllewell
 
Posts: 76
Joined: Thu Mar 01, 2012 4:06 pm

Re: Strategy debugger problem

Postby Ekaterina » Mon Oct 29, 2012 3:26 am

Hi tllewell,

If I reinstall the SDK, should I delete it first?


Yes, you need to delete it first and then install again. Then, please check that all standard indicators are in the following folder:<install_path>\indicators\standard. And all custom indicators are in the: <install_path>\indicators.

If all this doesn't help, then let us know!

Best regards,
Ekaterina
Ekaterina
 

Re: Strategy debugger problem

Postby protasithugz » Wed Nov 13, 2019 3:15 am

I have a similar challenge...

My strategy cannot find any new (downloaded/custom new) indicator. For all standard indicators it has no problem finding them.

Indicore is installed in the default path.

Every attempt at indicators:create -. with a downloaded or new indicator return a type - nill

What can I do to make the newdownloaded indicators visible in strategies?
protasithugz
 
Posts: 2
Joined: Mon Nov 11, 2019 6:56 am

Re: Strategy debugger problem

Postby Apprentice » Wed Nov 13, 2019 3:24 pm

Can you post your strategy code?
Note, all indicator/strategy names should be capitalized.
User avatar
Apprentice
FXCodeBase: Confirmed User
 
Posts: 26655
Joined: Thu Dec 31, 2009 11:59 am
Location: Zagreb, Croatia


Return to General Discussions

Who is online

Users browsing this forum: No registered users and 2 guests